Home/PowerShell/Windows PowerShell System Requirements

Windows PowerShell System Requirements

This topic we are going to discuss about the system requirements for Windows PowerShell 5.0 and its special features, such as Windows PowerShell Integrated Scripting Environment (ISE), CIM commands, and workflows.

Note:

Windows® 8.1 and Windows Server® 2012 R2 include all required programs so no need to install any thing special to work on powershell. This topic is designed for users of earlier releases of Windows. Windows PowerShell 4.0 runs on Windows 8.1, installed by default.

Operating System Requirements

  • Windows PowerShell 5.0 runs on the following versions of Windows.
  • Windows Server 2016, installed by default
  • Windows Server 2012 R2, install Windows Management Framework 5.0 to run Windows PowerShell 5.0
  • Windows Server 2012, install Windows Management Framework 5.0 to run Windows PowerShell 5.0
  • Windows Server 2008 R2 with Service Pack 1, install Windows Management Framework 5.0 to run Windows PowerShell 5.0
  • Windows 8.1 Windows 7 with Service Pack 1, install Windows Management Framework 5.0 to run Windows PowerShell 5.0

Microsoft .NET Framework Requirements

Windows PowerShell 5.0 requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.

 

Leave A Comment